Ledes from the Land of Enchantment

Hyundai Santa Fe gearbox issue: SUV moves forward even in neutral

The service center said that the automatic transmission is not serviceable & an entirely new unit would cost ~Rs 4 lakh.

BHPian electroguy recently shared this with other enthusiasts.

I have a Santa Fe 2015 4WD AT variant that has done 95k Kms. I bought it a year ago when it was at 75k. Except for a few minor issues, the condition was perfect. The interiors and exteriors both were shiny new, and the engine and gearbox were butter smooth (drawing reference from my Honda City IVTEC). I did around 20k kms in a year before I faced a major issue.

One day while stopping at a red light, I noticed vibrations while the car was in neutral and brakes pressed. On releasing the brakes, I could feel the car moving forward slightly. When I reached home, I checked again and the car was indeed having a forward momentum in Neutral and Park. While pressing the accelerator didn’t make the car go faster, there was a forward movement in Neutral (In Park, it did lock but I could feel the movement before it gets locked).

The next morning while trying to reverse from my parking, the reverse felt like it lacked momentum (otherwise it moved as soon as you let go of the brakes, without having much need to accelerate). On pressing the accelerator, it moved but with jerks which were very more than noticeable.

So I called up the ASC (Garve Hyundai, Pune) and explained the situation. They picked the car up and after inspecting it, said that the ATF has not been changed for quite a long time, and changing the ATF may solve the problem. I gave them a go ahead after doing my research on ATF. They charged around 19k for the entire thing and delivered the car back mentioning that the vibrations have reduced a lot, and told me that I can use the vehicle without any worry. I insisted that they diagnose if there is an issue with the gearbox, to which they said that the AT gearbox assembly is not serviceable, and if there is a problem with the gearbox, they will have to change the gearbox assembly, which will cost around 4 lacs. So I drove the vehicle for a few days and could see that the problem has not been resolved at all, with it being had exactly the same way.

I then took it to an FNG. They said that ATs are difficult to repair. In similar cases, they replace the gearbox with another one from a donor vehicle if they are able to locate one. However, that will also cost a good sum of money. So I started doing some research and discovered that this is a problem that can be traced to AT solenoids, which are located inside the gearbox assembly. I found some youtube videos (links at the end of the post) that showed how to diagnose and change those solenoids and sent them to the FNG. They said that they can diagnose it if I was okay with it. So one Sunday I went to them and we did the diagnostics, as well as cleaned all the solenoids. (BTW, the ATF was completely blackish-brown, looked like ASC did not change it and just charged me for it. The vehicle was not driven more than 200 Kms after the car came from ASC). However, all solenoids were working and none was faulty. After assembling, no change was seen in driving.

I am summarizing all the symptoms at this stage below-

  • In Neutral, the car moves forward (however does not accelerate on pressing the accelerator). The engine feels under load and vibrations are higher than normal.
  • In reverse, the car does not move without pressing the accelerator. On lightly pressing the accelerator, it moves with big jerks. However, on pressing the accelerator more, the jerks are not felt.
  • The first gear feels a bit abnormal when driving in high traffic, vibrations are higher and the engine rpm also drops below idle.
  • The car drives good at higher speeds (>30 KPH) and it’s difficult to tell if anything is wrong with the AT box.

2 weeks back, I took the car for a 100 km drive. A couple of times in the middle, it got stuck in 4th gear (which I checked by putting the shifter to manual mode), and it didn’t shift up or down in manual mode as well. I had to shut off the engine and restart it, and it was back in first gear. This happened 3-4 times.

A few days back, I again took it to drive. On the Mumbai expressway, it got stuck in 4th gear and this time on restarting, it didn’t come back to first. I had to get it towed since I had to reach somewhere on time. I later realized I shouldn’t have driven the car on the expressway with this kind of issue for safety reasons. Now, it doesn’t move forward at all, just goes into reverse, and surprisingly now the jerks of the reverse are gone.

I am keen to get the AT box replaced from a donor vehicle, but I also suspect that there could be issues outside the gearbox (TCM, ECM, wiring, etc.). The worst would be if I get it changed and the problem persists.

What do you guys think could be the problem here? I don’t trust the ASC, don’t know how they would help. Would also be of great help if anyone can give any leads on a used gearbox. Thanks in advance!

Links to youtube videos-

Here’s what BHPian hserus had to say about the matter:

Find an automatic transmission specialist rather than a regular FNG.

Try these guys, don’t know who they are but saw this ad on Olx

Check out BHPian comments for more insights and information.

Comments are closed.